hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sergey Shelukhin (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-10356) Failover RPC's for multi-get
Date Tue, 11 Feb 2014 01:44:21 GMT

    [ https://issues.apache.org/jira/browse/HBASE-10356?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13897426#comment-13897426

Sergey Shelukhin commented on HBASE-10356:

bq. Can we fix the naming? An Action instance with a method named getAction is confusing (not
you I know...)
Will do separate patch on trunk probably.

bq. Do I have the model wrong then? This Action is for accounting on how this 'Action' did
in the Multi request, right? My thinking is that server and region accounting is done outside
of the Action usually. I'd think which replica would be done there w/o needing to mark this
index on the Multi call.
I don't think Action has any particular model, it's just a context between request and response

bq. The new Runnables need explanatory comments and better names . Should the two types be
related? Subclass? Do we need two Callable types?
Two types are not related. Will rename and add comments.

> Failover RPC's for multi-get 
> -----------------------------
>                 Key: HBASE-10356
>                 URL: https://issues.apache.org/jira/browse/HBASE-10356
>             Project: HBase
>          Issue Type: Sub-task
>          Components: Client
>            Reporter: Enis Soztutar
>            Assignee: Sergey Shelukhin
>             Fix For: 0.99.0
>         Attachments: HBASE-10356.reference.patch, HBASE-10356.reference.patch
> This is extension of HBASE-10355 to add failover support for multi-gets. 

This message was sent by Atlassian JIRA

View raw message