hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-7320) Remove KeyValue.getBuffer()
Date Fri, 14 Feb 2014 06:39:24 GMT

    [ https://issues.apache.org/jira/browse/HBASE-7320?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13901158#comment-13901158
] 

stack commented on HBASE-7320:
------------------------------

bq. Fine with moving to CellUtil then.

It might not work but worth giving it a go I'd say.  You'll have a better argument for why
Cell needs to implement HeapSize after trying (smile).

bq. So CellUtil would be talking with a factory that knows how the cell was created right?

I hope not.  Should just ask the Cell.  This might be an argument for Cell implementing HeapSize
(It knows how much space it has occupied, it knows if its data is compressed on heap so will
return the Cell overhead + compressed sizes whereas a KV will return the size of the backing
array.

bq.  So we are agreeing to change the KeyValue format as mentioned in this blog...

That is a nice old Matteo blog.  It suggests one way of packing keys, a method we should pursue....
but this will not be the only one.  Thinking about this I'd suggest keep in mind Cells that
could be formatted as our current KeyValue is, how Matteo describes it in his block, and then
a third format would be the PrefixTree encoding that is a module here in hbase; i.e. the content
stays encoded even as we traverse it.

bq. ...the way we form this combination may vary.

yes

bq. Sorry if am asking too many questions and going off track

Smile.  Thanks for digging in here [~ram_krish]

> Remove KeyValue.getBuffer()
> ---------------------------
>
>                 Key: HBASE-7320
>                 URL: https://issues.apache.org/jira/browse/HBASE-7320
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Lars Hofhansl
>            Assignee: stack
>             Fix For: 0.99.0
>
>         Attachments: 7320-simple.txt
>
>
> In many places this is simple task of just replacing the method name.
> There, however, quite a few places where we assume that:
> # the entire KV is backed by a single byte array
> # the KVs key portion is backed by a single byte array
> Some of those can easily be fixed, others will need their own jiras.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message