hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-10354) Add an API for defining consistency per request
Date Fri, 31 Jan 2014 06:50:09 GMT

    [ https://issues.apache.org/jira/browse/HBASE-10354?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13887528#comment-13887528
] 

stack commented on HBASE-10354:
-------------------------------

bq. We can rename Consistency.EVENTUAL to Consistency.TIMELINE if there is concern that it
will cause confusion.

+1 on above... TIMELINE or STALE or STALE_ALLOWED?

Do we have to have a pb and java enum?  Maybe for the client API but does it have show up
on the server?  Can it just be pb enum on server (Answer is probably no but asking anyway).

This has to be public?

+  public void setStale(boolean stale) {
+    this.stale = stale;

It can't be done on construction of the Result?  (Are Results iimmutable?)  Maybe it has to
be public for unmarshalling to work?

Otherwise patch is good.  This going into a branch?





> Add an API for defining consistency per request
> -----------------------------------------------
>
>                 Key: HBASE-10354
>                 URL: https://issues.apache.org/jira/browse/HBASE-10354
>             Project: HBase
>          Issue Type: Sub-task
>          Components: Client
>            Reporter: Enis Soztutar
>            Assignee: Enis Soztutar
>             Fix For: 0.99.0
>
>         Attachments: hbase-10354_v1.patch
>
>
> We should add an API to be able to define the expected consistency level per operation.
This API should also allow to check whether the results coming from a query (get or scan)
is stale or not. The defaults should reflect the current semantics. 



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message