hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lars Hofhansl (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (HBASE-7320) Replace calls to KeyValue.getBuffer with appropropriate calls to getRowArray, getFamilyArray(), getQualifierArray, and getValueArray
Date Wed, 22 Jan 2014 04:47:27 GMT

    [ https://issues.apache.org/jira/browse/HBASE-7320?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13878255#comment-13878255
] 

Lars Hofhansl edited comment on HBASE-7320 at 1/22/14 4:46 AM:
---------------------------------------------------------------

If we all agree that is OK to store row, family, qualifier, and value continuously in ram,
I can knock off all the simple cases next week.
Note that that would work for block encoding, where we would no longer need to re-materialize
the KV just so that the entire KV is stored continuously; but it would not help with prefix
tries, as there we'd even want to store partial rows, families, etc. (Correct [~mcorgan]?)



was (Author: lhofhansl):
If we all agree that is OK to store row, family, qualifier, and value continuously in ram,
I can knock off all the simple case next week.
Note that that would for block encoding, where we would no longer need to rematerialize the
KV just so that the entire KV is stored continuously; but it would not help with the prefixtries,
as there we'd even want to store partial rows, families, etc. (Correct [~mcorgan]?)


> Replace calls to KeyValue.getBuffer with appropropriate calls to getRowArray, getFamilyArray(),
getQualifierArray, and getValueArray
> ------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: HBASE-7320
>                 URL: https://issues.apache.org/jira/browse/HBASE-7320
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Lars Hofhansl
>            Assignee: stack
>             Fix For: 0.98.0
>
>
> In many places this is simple task of just replacing the method name.
> There, however, quite a few places where we assume that:
> # the entire KV is backed by a single byte array
> # the KVs key portion is backed by a single byte array
> Some of those can easily be fixed, others will need their own jiras.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message