hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-5923) Cleanup checkAndXXX logic
Date Sat, 04 Jan 2014 19:41:50 GMT

    [ https://issues.apache.org/jira/browse/HBASE-5923?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13862397#comment-13862397
] 

Hudson commented on HBASE-5923:
-------------------------------

SUCCESS: Integrated in HBase-TRUNK-on-Hadoop-1.1 #42 (See [https://builds.apache.org/job/HBase-TRUNK-on-Hadoop-1.1/42/])
HBASE-5923 Cleanup checkAndXXX logic (Tedyu: rev 1555351)
* /hbase/trunk/hbase-client/src/main/java/org/apache/hadoop/hbase/client/HTable.java
* /hbase/trunk/hbase-client/src/main/java/org/apache/hadoop/hbase/client/HTableInterface.java
* /hbase/trunk/hbase-client/src/main/java/org/apache/hadoop/hbase/client/HTablePool.java
* /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/coprocessor/CoprocessorHost.java
* /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/rest/client/RemoteHTable.java
* /hbase/trunk/hbase-server/src/test/java/org/apache/hadoop/hbase/client/TestFromClientSide.java


> Cleanup checkAndXXX logic
> -------------------------
>
>                 Key: HBASE-5923
>                 URL: https://issues.apache.org/jira/browse/HBASE-5923
>             Project: HBase
>          Issue Type: Improvement
>          Components: Client, regionserver
>            Reporter: Lars Hofhansl
>            Assignee: Feng Honghua
>              Labels: noob
>             Fix For: 0.99.0
>
>         Attachments: 5923-0.94.txt, 5923-trunk.txt, HBASE-10262-trunk_v0.patch
>
>
> 1. the checkAnd{Put|Delete} method that takes a CompareOP is not exposed via HTable[Interface].
> 2. there is unnecessary duplicate code in the check{Put|Delete} code in HRegionServer.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message