hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Feng Honghua (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-5923) Cleanup checkAndXXX logic
Date Thu, 02 Jan 2014 03:07:52 GMT

     [ https://issues.apache.org/jira/browse/HBASE-5923?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Feng Honghua updated HBASE-5923:
--------------------------------

    Attachment: HBASE-10262-trunk_v0.patch

trunk patch attached:
1. only CompareOp introduced as new argument, not proto. CompareType
2. LESS/GREATER use implied binary comparator
3. no wire protocol change

> Cleanup checkAndXXX logic
> -------------------------
>
>                 Key: HBASE-5923
>                 URL: https://issues.apache.org/jira/browse/HBASE-5923
>             Project: HBase
>          Issue Type: Improvement
>          Components: Client, regionserver
>            Reporter: Lars Hofhansl
>              Labels: noob
>         Attachments: 5923-0.94.txt, 5923-trunk.txt, HBASE-10262-trunk_v0.patch
>
>
> 1. the checkAnd{Put|Delete} method that takes a CompareOP is not exposed via HTable[Interface].
> 2. there is unnecessary duplicate code in the check{Put|Delete} code in HRegionServer.



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message