hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Feng Honghua (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-5923) Cleanup checkAndXXX logic
Date Thu, 02 Jan 2014 03:03:51 GMT

    [ https://issues.apache.org/jira/browse/HBASE-5923?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13859998#comment-13859998

Feng Honghua commented on HBASE-5923:

background: I created a jira [HBASE-10262|https://issues.apache.org/jira/browse/HBASE-10262]
for the same goal, so I move here for continuous discussion, :-)

bq. If we allow control of the compareOp we need to allow for different comparators as well
(for LESS, etc) Or we can punt on that and just force binary comparator as we do not for EQUAL
==> I agree above because (for trunk):
1. only CompareOp exposed to HTable/HTableInterface interface, no proto. type introduced,
so it's clean
2. no wire protocol change, so it's lightweight
3.non-equal comparison operations such as LESS/GREATER use implied BinaryComparator which
is reasonable/acceptable

also attach patch for [HBASE-10262|https://issues.apache.org/jira/browse/HBASE-10262] here
for reference, a similar patch has been applied in our internal branch and worked fine for
quite a long time. :-)

> Cleanup checkAndXXX logic
> -------------------------
>                 Key: HBASE-5923
>                 URL: https://issues.apache.org/jira/browse/HBASE-5923
>             Project: HBase
>          Issue Type: Improvement
>          Components: Client, regionserver
>            Reporter: Lars Hofhansl
>              Labels: noob
>         Attachments: 5923-0.94.txt, 5923-trunk.txt
> 1. the checkAnd{Put|Delete} method that takes a CompareOP is not exposed via HTable[Interface].
> 2. there is unnecessary duplicate code in the check{Put|Delete} code in HRegionServer.

This message was sent by Atlassian JIRA

View raw message