hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-10186) region_mover.rb broken because ServerName constructor is changed to private
Date Wed, 18 Dec 2013 01:46:10 GMT

    [ https://issues.apache.org/jira/browse/HBASE-10186?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13851228#comment-13851228
] 

Hudson commented on HBASE-10186:
--------------------------------

FAILURE: Integrated in HBase-TRUNK-on-Hadoop-1.1 #9 (See [https://builds.apache.org/job/HBase-TRUNK-on-Hadoop-1.1/9/])
HBASE-10186 region_mover.rb broken because ServerName constructor is changed to private (Samir
Ahmic) (jmhsieh: rev 1551532)
* /hbase/trunk/bin/region_mover.rb


> region_mover.rb broken because ServerName constructor is changed to private
> ---------------------------------------------------------------------------
>
>                 Key: HBASE-10186
>                 URL: https://issues.apache.org/jira/browse/HBASE-10186
>             Project: HBase
>          Issue Type: Bug
>          Components: scripts
>    Affects Versions: 0.96.1
>         Environment: x86_64 GNU/Linux
>            Reporter: Samir Ahmic
>            Assignee: Samir Ahmic
>             Fix For: 0.98.0, 0.96.2, 0.99.0
>
>         Attachments: HBASE-10186.patch
>
>
> After upgrading to 0.96.1 (from 0.96.0) i have tried rolling restart with ./rolling-restart.sh
--graceful but region_mover.rb throws error:
> {code}
> TypeError: no public constructors for Java::OrgApacheHadoopHbase::ServerName
>      getRegions at ./region_mover.rb:257
>   unloadRegions at ./region_mover.rb:318
>          (root) at ./region_mover.rb:461
> {code}
> After checking region_mover.rb i believe  this line:
> {code}
> return ProtobufUtil::getOnlineRegions(connection.getAdmin(ServerName.new(servername)));
> {code}
> should be changed to
> {code}
> return ProtobufUtil::getOnlineRegions(connection.getAdmin(ServerName.valueOf(servername)));
> {code}
> After making this change region_mover.rb is working again. I will attach patch shortly.




--
This message was sent by Atlassian JIRA
(v6.1.4#6159)

Mime
View raw message