hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Elliott Clark (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-9729) mvn site fails without install first
Date Wed, 11 Dec 2013 21:29:07 GMT

     [ https://issues.apache.org/jira/browse/HBASE-9729?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Elliott Clark updated HBASE-9729:
---------------------------------

    Attachment: HBASE-9729-0.patch

Here's a patch that installs first so that site can work.

> mvn site fails without install first
> ------------------------------------
>
>                 Key: HBASE-9729
>                 URL: https://issues.apache.org/jira/browse/HBASE-9729
>             Project: HBase
>          Issue Type: Bug
>          Components: build, documentation
>            Reporter: Enis Soztutar
>         Attachments: HBASE-9729-0.patch
>
>
> mvn site fails on hadoopqa runs, and also on fresh checkouts. The problem seems to be
that mvn site somehow does not trigger a correct reactor ordering. hbase-server is built before
other components, and thus throws dependency errors because the other modules are not build
yet. 
> An example from https://builds.apache.org/job/PreCommit-HBASE-Build/7491//consoleFull:

> {code}
> /home/jenkins/tools/maven/latest/bin/mvn compile site -DskipTests -DHBasePatchProcess
> /home/jenkins/jenkins-slave/workspace/PreCommit-HBASE-Build/patchprocess/patchSiteOutput.txt
2>&1
> {code}



--
This message was sent by Atlassian JIRA
(v6.1.4#6159)

Mime
View raw message