hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-7088) Duplicate code in RowCounter
Date Thu, 19 Dec 2013 03:24:08 GMT

    [ https://issues.apache.org/jira/browse/HBASE-7088?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13852560#comment-13852560
] 

Hudson commented on HBASE-7088:
-------------------------------

SUCCESS: Integrated in HBase-TRUNK #4737 (See [https://builds.apache.org/job/HBase-TRUNK/4737/])
HBASE-7088 Duplicate code in RowCounter (stack: rev 1552155)
* /hbase/trunk/hbase-server/src/main/java/org/apache/hadoop/hbase/mapreduce/RowCounter.java


> Duplicate code in RowCounter
> ----------------------------
>
>                 Key: HBASE-7088
>                 URL: https://issues.apache.org/jira/browse/HBASE-7088
>             Project: HBase
>          Issue Type: Improvement
>          Components: mapreduce
>    Affects Versions: 0.96.1, 0.94.14, 0.98.1, 0.99.0
>            Reporter: Jean-Marc Spaggiari
>            Assignee: Jean-Marc Spaggiari
>            Priority: Minor
>              Labels: mapreduce
>             Fix For: 0.99.0
>
>         Attachments: HBASE-7088-v1-trunk.patch, HBASE-7088-v2-trunk.patch, HBASE-7088.patch
>
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> On the RowCounter mapreduce class, there is a "scan.setFilter(new FirstKeyOnlyFilter());"
statement which is not required at line 125 since we have this on line 141:
> {code}
>     if (qualifiers.size() == 0) {
>       scan.setFilter(new FirstKeyOnlyFilter());
>     } else {
>       scan.setFilter(new FirstKeyValueMatchingQualifiersFilter(qualifiers));
>     }
> {code}
> Should the line 125 simply be removed?



--
This message was sent by Atlassian JIRA
(v6.1.4#6159)

Mime
View raw message