hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nick Dimiduk (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-9702) Change unittests that use "table" or "testtable" to use method names.
Date Wed, 02 Oct 2013 21:45:46 GMT

    [ https://issues.apache.org/jira/browse/HBASE-9702?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13784478#comment-13784478
] 

Nick Dimiduk commented on HBASE-9702:
-------------------------------------

Yes please :)

> Change unittests that use "table" or "testtable" to use method names.
> ---------------------------------------------------------------------
>
>                 Key: HBASE-9702
>                 URL: https://issues.apache.org/jira/browse/HBASE-9702
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Jonathan Hsieh
>
> While working on HBASE-9686, many tests left files that indicated the method they had
come from but several drop data in "table" or "testtable" tables.  Naming them this way makes
it hard to track which tests these came from.  We should make all test use 
> @Rule TestName name = new TestName();
> ...
> TableName  t = TableName.valueOf(name.getMethodName());



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message