hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Elliott Clark (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-9555) Reset loadbalancer back to StochasticLoadBalancer
Date Tue, 17 Sep 2013 03:55:52 GMT

    [ https://issues.apache.org/jira/browse/HBASE-9555?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13769167#comment-13769167

Elliott Clark commented on HBASE-9555:

Yeah it's bad naming.  Pretty sure that 0.94 had the ability to set which lb to use.  So I
didn't change the name just in case someone had derived something from it.  But then we put
on interface audience private. I'm +1 on renaming it to something like SimpleBalancer.  But
we run a small (very small in my opinion) risk of breaking people.

So JMS seemed to think that documenting the config was worth it.  Should we just change the
value to StochasticLoadBalancer ?
> Reset loadbalancer back to StochasticLoadBalancer
> -------------------------------------------------
>                 Key: HBASE-9555
>                 URL: https://issues.apache.org/jira/browse/HBASE-9555
>             Project: HBase
>          Issue Type: Bug
>          Components: Balancer
>    Affects Versions: 0.96.0
>            Reporter: Elliott Clark
>            Priority: Critical
>             Fix For: 0.96.0
> It seems like HBASE-7296 changed the loadbalancer class by mistake, removing a good deal
of functionality.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message