hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jonathan Hsieh (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-9493) Rename CellUtil#get*Array to CellUtil#clone*
Date Tue, 10 Sep 2013 20:45:52 GMT
Jonathan Hsieh created HBASE-9493:

             Summary: Rename CellUtil#get*Array to CellUtil#clone*
                 Key: HBASE-9493
                 URL: https://issues.apache.org/jira/browse/HBASE-9493
             Project: HBase
          Issue Type: Sub-task
            Reporter: Jonathan Hsieh

To make reading code easier, we should rename the CellUtil#get*Array methods (Value,Qualifier,Family,Row)
to to CellUtil#clone*.  This eliminates the possibly confusion between the semantics of these
methods (which allocate-copy) and that of Cell#get*Array (which essentially just returns a

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message