hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "chendihao (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-9138) the name of function getHaseIntegrationTestingUtility() is a misspelling
Date Tue, 06 Aug 2013 11:12:49 GMT

     [ https://issues.apache.org/jira/browse/HBASE-9138?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

chendihao updated HBASE-9138:
-----------------------------

    Description: 
The function getHaseIntegrationTestingUtility() in ChaosMonkey.java should be getHBaseIntegrationTestingUtility(),
just a spelling mistake.

{code}
  /**                                                                                    
                                         
   * Context for Action's                                                                
                                         
   */
  public static class ActionContext {
    private IntegrationTestingUtility util;

    public ActionContext(IntegrationTestingUtility util) {
      this.util = util;
    }

    public IntegrationTestingUtility getHaseIntegrationTestingUtility() {
      return util;
    }

    public HBaseCluster getHBaseCluster() {
      return util.getHBaseClusterInterface();
    }
  }
{code}

  was:
The function getHaseIntegrationTestingUtility() in ChaosMonkey.java should be getHBaseIntegrationTestingUtility(),
just a misspelling.

{code}
  /**                                                                                    
                                         
   * Context for Action's                                                                
                                         
   */
  public static class ActionContext {
    private IntegrationTestingUtility util;

    public ActionContext(IntegrationTestingUtility util) {
      this.util = util;
    }

    public IntegrationTestingUtility getHaseIntegrationTestingUtility() {
      return util;
    }

    public HBaseCluster getHBaseCluster() {
      return util.getHBaseClusterInterface();
    }
  }
{code}

    
> the name of function getHaseIntegrationTestingUtility() is a misspelling
> ------------------------------------------------------------------------
>
>                 Key: HBASE-9138
>                 URL: https://issues.apache.org/jira/browse/HBASE-9138
>             Project: HBase
>          Issue Type: Bug
>          Components: test
>    Affects Versions: 0.94.8
>            Reporter: chendihao
>            Priority: Trivial
>         Attachments: ChaosMonkey.java.patch
>
>
> The function getHaseIntegrationTestingUtility() in ChaosMonkey.java should be getHBaseIntegrationTestingUtility(),
just a spelling mistake.
> {code}
>   /**                                                                               
                                              
>    * Context for Action's                                                           
                                              
>    */
>   public static class ActionContext {
>     private IntegrationTestingUtility util;
>     public ActionContext(IntegrationTestingUtility util) {
>       this.util = util;
>     }
>     public IntegrationTestingUtility getHaseIntegrationTestingUtility() {
>       return util;
>     }
>     public HBaseCluster getHBaseCluster() {
>       return util.getHBaseClusterInterface();
>     }
>   }
> {code}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message