hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-8408) Implement namespace
Date Fri, 02 Aug 2013 06:25:51 GMT

    [ https://issues.apache.org/jira/browse/HBASE-8408?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13727398#comment-13727398
] 

stack commented on HBASE-8408:
------------------------------

I was having trouble up in rb loading page #3 so moved to raw patch.  Here is some feedback
up to TableSplit:

{code}

+ hbase-common/src/main/java/org/apache/hadoop/hbase/HConstants.java

Good you upped the fs version number.

I wonder if the tablename defines don't better belong in the new TableName class.

On the name of the datadir being .data, is that right?  Did we talk about
changing the names of dirs after ns goes in to remove the '.' ?  Would that be after
this patch?

+ hbase-common/src/main/java/org/apache/hadoop/hbase/KeyValue.java

So the system ns is called 'hbase' and not 'system'?  HConstants.META_TABLE_NAME.getName().length;
// 'hbase.meta' length

+ hbase-common/src/main/java/org/apache/hadoop/hbase/NamespaceDescriptor.java

Looks good.  When we list them, they will look like an HTableDescriptor listing in
the ruby map format.... Thats consistent (if ugly but ugly ain't your fault)

+ hbase-common/src/main/java/org/apache/hadoop/hbase/TableName.java

I suppose it is ok haveing NS and TN in hbase-common.  They have no dependency on anything
else.

What is a qualifier name in TN?  A ns?  Or it looks like it is the old tablename?  Should
say
in javadoc since can confuse

TN#valueOf(byte []) and TN#valueOf(String) duplicate code.

Yeah, add some javadoc on what qualifier is.  An example?  Yeah, javadoc needs examples.

Fix javadoc (missing @param)

+ hbase-server/src/main/java/org/apache/hadoop/hbase/NamespaceUpgrade.java

Suggest putting this class into a migration subpackage (it is where we used to put
shortlived migration classes in the past -- see 0.92... )

The class javadoc is off.... we use ':' now?

Looking at this script, can it resume if it fails midway through a migration and it then
gets restarted again?  It does not look like it.

Good that it implements Tool.

Does it change the fs file version?  I don't see it.

+ hbase-server/src/main/java/org/apache/hadoop/hbase/io/HFileLink.java

You have unit test for your new hfilelink regex?

You have a note about ':' being illegal but it is floating in the middle of the file
unattached.

Yeah, do these changes have test coverage?
{code}

More to come.
                
> Implement namespace
> -------------------
>
>                 Key: HBASE-8408
>                 URL: https://issues.apache.org/jira/browse/HBASE-8408
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Francis Liu
>            Assignee: Francis Liu
>         Attachments: HBASE-8015_11.patch, HBASE-8015_1.patch, HBASE-8015_2.patch, HBASE-8015_3.patch,
HBASE-8015_4.patch, HBASE-8015_5.patch, HBASE-8015_6.patch, HBASE-8015_7.patch, HBASE-8015_8.patch,
HBASE-8015_9.patch, HBASE-8015.patch, TestNamespaceMigration.tgz, TestNamespaceUpgrade.tgz
>
>


--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message