hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-8348) Polish the migration to 0.96
Date Sun, 18 Aug 2013 00:15:49 GMT

    [ https://issues.apache.org/jira/browse/HBASE-8348?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13743067#comment-13743067
] 

stack commented on HBASE-8348:
------------------------------

+  echo "  upgradeTo96      upgrade hbase to 0.96"

On above, just say upgrade'.  And help should be 'upgrade from 0.94 (or 0.92)?'.

The below is odd...

-  private static byte[] toByteArray(final String clusterKey) {
+  public static byte[] toByteArray(final String clusterKey) {

If it is going to be made public, it should probably get a better name (but I can't come up
w/ one -- smile) so maybe just having the parameter name be clusterKey works.... does this
have to be public?

Why not an accessor rather than make a private member public?

-  private String masterAddressZNode;
+  public String masterAddressZNode;

On Upgrade script, I'd suggest that user runs 'check' then print out "regions xyz need major
compacting..... see refguide link for more"

Then for executing the upgrade, yeah, as [~rajesh23] suggests, should check if stuff is running
and not run if stuff is.

I'd say that operator probably doesn't care about znodes and ns steps upgrading, not until
it goes wrong (but it won't go wrong!).  In refguide we can talk up the steps and what each
does.  So would suggest making this less detailed:

+        "Upgrade both namespace and znodes"));


These usage Strings are too long:

+    System.out.println("This tool helps in upgrading to 0.96. The upgrade involves major
" +
+    		"compacting any HFileV1, upgrading file system layout for namespaces, and updating
" +
+    		"znodes. Please follow the following steps:");

Usually folks keep the usage 80 characters wide.  Would suggest you just point folks to the
refguide 0.96 migration section.   There we can do the detail rather than here.

Otherwise, this stuff is looking really good.  Thanks for working on it lads.
                
> Polish the migration to 0.96
> ----------------------------
>
>                 Key: HBASE-8348
>                 URL: https://issues.apache.org/jira/browse/HBASE-8348
>             Project: HBase
>          Issue Type: Bug
>    Affects Versions: 0.95.0
>            Reporter: Jean-Daniel Cryans
>            Assignee: rajeshbabu
>            Priority: Critical
>             Fix For: 0.96.0
>
>         Attachments: HBASE-8348-approach-2.patch, HBASE-8348-approach-3.patch, HBASE-8348_trunk.patch,
HBASE-8348_trunk_v2.patch, HBASE-8348_trunk_v3.patch
>
>
> Currently, migration works but there's still a couple of rough edges:
>  - HBASE-8045 finished the .META. migration but didn't remove ROOT, so it's still on
the filesystem.
>  - Data in ZK needs to be removed manually. Either we fix up the data in ZK or we delete
it ourselves.
>  - TestMetaMigrationRemovingHTD has a testMetaUpdatedFlagInROOT method, but ROOT is gone
now.
> Elliott was also mentioning that we could have "hbase migrate" do the HFileV1 checks,
clear ZK, remove ROOT, etc.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message