hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-9042) Can't get TestHCM#testClusterStatus to work
Date Sat, 27 Jul 2013 00:15:49 GMT

    [ https://issues.apache.org/jira/browse/HBASE-9042?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13721420#comment-13721420
] 

stack commented on HBASE-9042:
------------------------------

Weird.  It hangs for 40 seconds in here:

{code}
2013-07-21 22:12:31,038 INFO  [AM.ZK.Worker-pool-4-thread-16] master.AssignmentManager$4(1223):
The master has opened testClusterStatus,,1374437547649.f02a31af489a311d2a63454a13db9b09. that
was online on lars-francke.com,38941,1374437536925
2013-07-21 22:13:10,133 INFO  [pool-1-thread-1] hbase.ResourceChecker(171): after: client.TestHCM#testClusterStatus
Thread=288 (was 275)
{code}

I don't have time to dig.  I want to disable this test for now so the likes of yourself can
make progress.  OK w/ you [~lars_francke]?
                
> Can't get TestHCM#testClusterStatus to work
> -------------------------------------------
>
>                 Key: HBASE-9042
>                 URL: https://issues.apache.org/jira/browse/HBASE-9042
>             Project: HBase
>          Issue Type: Bug
>          Components: test
>            Reporter: Lars Francke
>            Priority: Minor
>         Attachments: HBASE-9042.1.txt
>
>
> I can't get HBase trunk to build. In particular TestHCM.testClusterStatus always fails
for me. I tried on my own Jenkins as well as my IDE (IntelliJ) with the same result (two different
machines, CentOS & Mac OS).
> mvn -U -PrunAllTests -Dmaven.test.redirectTestOutputToFile=true
> -Dit.test=noItTest clean install
> I've attached the full log. It fails on the last wait by exceeding the timeout. This
is reported:
> {code}
>  - Thread LEAK? -, OpenFileDescriptor=417 (was 440), MaxFileDescriptor=4096 (was 4096),
SystemLoadAverage=227 (was 265), ProcessCount=243 (was 240) - ProcessCount LEAK? -, AvailableMemoryMB=2196
(was 1991) - AvailableMemoryMB LEAK? -, ConnectionCount=7 (was 6) - ConnectionCount LEAK?
-
> {code}
> And the Thread dump (see attached file) has a bunch of things reported as potentially
hanging threads.
> From my MacBook's command line I got the test to pass using the same
> command but not in Jenkins or from IntelliJ.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message