hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-8915) protobuf message style
Date Wed, 10 Jul 2013 07:41:50 GMT

    [ https://issues.apache.org/jira/browse/HBASE-8915?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13704284#comment-13704284
] 

Hadoop QA commented on HBASE-8915:
----------------------------------

{color:red}-1 overall{color}.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12591599/8915.v1.patch
  against trunk revision .

    {color:green}+1 @author{color}.  The patch does not contain any @author tags.

    {color:green}+1 tests included{color}.  The patch appears to include 3 new or modified
tests.

    {color:green}+1 hadoop1.0{color}.  The patch compiles against the hadoop 1.0 profile.

    {color:green}+1 hadoop2.0{color}.  The patch compiles against the hadoop 2.0 profile.

    {color:green}+1 javadoc{color}.  The javadoc tool did not generate any warning messages.

    {color:green}+1 javac{color}.  The applied patch does not increase the total number of
javac compiler warnings.

    {color:green}+1 findbugs{color}.  The patch does not introduce any new Findbugs (version
1.3.9) warnings.

    {color:green}+1 release audit{color}.  The applied patch does not increase the total number
of release audit warnings.

    {color:red}-1 lineLengths{color}.  The patch introduces lines longer than 100

    {color:red}-1 site{color}.  The patch appears to cause mvn site goal to fail.

    {color:green}+1 core tests{color}.  The patch passed unit tests in .

Test results: https://builds.apache.org/job/PreCommit-HBASE-Build/6289//testReport/
Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/6289//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-protocol.html
Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/6289//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-client.html
Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/6289//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-examples.html
Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/6289//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop1-compat.html
Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/6289//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-prefix-tree.html
Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/6289//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-common.html
Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/6289//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-server.html
Findbugs warnings: https://builds.apache.org/job/PreCommit-HBASE-Build/6289//artifact/trunk/patchprocess/newPatchFindbugsWarningshbase-hadoop-compat.html
Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/6289//console

This message is automatically generated.
                
> protobuf message style
> ----------------------
>
>                 Key: HBASE-8915
>                 URL: https://issues.apache.org/jira/browse/HBASE-8915
>             Project: HBase
>          Issue Type: Improvement
>          Components: Protobufs
>            Reporter: Dan Burkert
>            Priority: Minor
>         Attachments: 8915.v1.patch
>
>
> Google's protobuf style guide (https://developers.google.com/protocol-buffers/docs/style)
lays out the convention that message field names should be underscore_separated and services
should be MixedCase. The .proto's in trunk do not follow this style; instead they follow Java
naming conventions. The protobuf compiler will automatically change the style of names to
match the language it is compiling for, but it is unable to do so if the protobuf style is
not used. As a result, using the HBase proto files from languages with different naming conventions
than Java is a little bit more painful.
> Since a core feature of moving to protobufs is opening the door to wire compatible implementations
in other languages, I think this may want to be addressed. This patch changes the naming convention
in the protos. The resulting .java files that the protobuf compiler puts out are functionally
the same (with the same correct Java naming style).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message