hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dan Burkert (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-8915) protobuf message style
Date Wed, 10 Jul 2013 06:29:48 GMT

     [ https://issues.apache.org/jira/browse/HBASE-8915?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Dan Burkert updated HBASE-8915:
-------------------------------

    Status: Patch Available  (was: Open)
    
> protobuf message style
> ----------------------
>
>                 Key: HBASE-8915
>                 URL: https://issues.apache.org/jira/browse/HBASE-8915
>             Project: HBase
>          Issue Type: Improvement
>          Components: Protobufs
>            Reporter: Dan Burkert
>            Priority: Minor
>         Attachments: 8915.v1.patch
>
>
> Google's protobuf style guide (https://developers.google.com/protocol-buffers/docs/style)
lays out the convention that message field names should be underscore_separated and services
should be MixedCase. The .proto's in trunk do not follow this style; instead they follow Java
naming conventions. The protobuf compiler will automatically change the style of names to
match the language it is compiling for, but it is unable to do so if the protobuf style is
not used. As a result, using the HBase proto files from languages with different naming conventions
than Java is a little bit more painful.
> Since a core feature of moving to protobufs is opening the door to wire compatible implementations
in other languages, I think this may want to be addressed. This patch changes the naming convention
in the protos. The resulting .java files that the protobuf compiler puts out are functionally
the same (with the same correct Java naming style).

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message