hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Enis Soztutar (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-8200) Integration Test classes are not part of the default HBase classpath. We should fix this or note workaround in documentation
Date Mon, 08 Jul 2013 21:27:49 GMT

     [ https://issues.apache.org/jira/browse/HBASE-8200?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Enis Soztutar updated HBASE-8200:
---------------------------------

    Attachment: hbase-8200_v1.patch

How about this patch? 
It moved classpath generation from hbase-it to hbase-assembly. 
                
> Integration Test classes are not part of the default HBase classpath. We should fix this
or note workaround in documentation
> ----------------------------------------------------------------------------------------------------------------------------
>
>                 Key: HBASE-8200
>                 URL: https://issues.apache.org/jira/browse/HBASE-8200
>             Project: HBase
>          Issue Type: Bug
>          Components: test
>         Environment: ubuntu
>            Reporter: Aleksandr Shulman
>         Attachments: hbase-8200_v1.patch
>
>
> Expected behavior:
> Following the instructions here:
> http://hbase.apache.org/book/hbase.tests.html#integration.tests
> After pulling down the latest bits from trunk and running,
> > mvn clean compile test-compile package install assembly:assembly -DskipTests
> I should be able to run integration tests with the following command:
> > bin/hbase --config /path/to/configs  org.apache.hadoop.hbase.IntegrationTestsDriver
> According to the documentation, this should kick off the tests.
> Observed behavior:
> Upon executing 
> > bin/hbase --config /path/to/configs  org.apache.hadoop.hbase.IntegrationTestsDriver
> I see the following:
> Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/hadoop/hbase/IntegrationTestsDriver
> Caused by: java.lang.ClassNotFoundException: org.apache.hadoop.hbase.IntegrationTestsDriver
> 	at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
> 	at java.security.AccessController.doPrivileged(Native Method)
> 	at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
> 	at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
> 	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
> 	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
> I can fix it by adding the following line to the hbase-env.sh file corresponding to the
configs:
> export HBASE_CLASSPATH=/path/to/project/hbase/hbase-it/target/test-classes/
> This produces the correct output.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message