hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Nicolas Liochon (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-8625) Dependency version upgrade
Date Mon, 27 May 2013 09:24:25 GMT

    [ https://issues.apache.org/jira/browse/HBASE-8625?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13667654#comment-13667654
] 

Nicolas Liochon commented on HBASE-8625:
----------------------------------------

bq. We need junit to make the hbase-it tests run (HBASE-8421).
Ok. I would expect then that hbase-it adds a dependency with scope compile while the others
uses the scope test.
v2 is without changing the junit scope. I will commit if the tests are ok.
                
> Dependency version upgrade
> --------------------------
>
>                 Key: HBASE-8625
>                 URL: https://issues.apache.org/jira/browse/HBASE-8625
>             Project: HBase
>          Issue Type: Improvement
>    Affects Versions: 0.98.0, 0.95.0
>            Reporter: Nicolas Liochon
>            Assignee: Nicolas Liochon
>            Priority: Minor
>             Fix For: 0.98.0
>
>         Attachments: 8625.v1.patch, 8625.v2.patch
>
>
> junit dependency should be scoped "test"
> We should use a newer versions of jaxb-api. One of our 3rd party would prefer a newer
one: 
>  javax.xml.bind:jaxb-api:jar:2.1:compile (version managed from 2.2.2)
>  Last is 2.2.4.
>  
> Not mandatory, but should be done:
>  guava 14.0.1
>  netty 3.6.6.Final
>  commons-codec.version 1.8
>  jackson.version 1.9.3

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message