hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ted Yu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-7904) Make mapreduce jobs pass based on 2.0.4-alpha
Date Mon, 01 Apr 2013 21:17:17 GMT

    [ https://issues.apache.org/jira/browse/HBASE-7904?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13619175#comment-13619175
] 

Ted Yu commented on HBASE-7904:
-------------------------------

bq. Why is this JIRA still open?
0.95 should not ship with 2.0.4-SNAPSHOT build. That was why I left this open.
If this JIRA is resolved, we can open another JIRA to update pom.xml when 2.0.4-ALPHA is released.

bq. this patch changes how RegionCoprocessorHost is instantiated
I exchanged a few emails with Nicolas who was the author of CompoundConfiguration.
My initial plan was to allow CompoundConfiguration.setClass() to be called. He advised against
that approach because CompoundConfiguration was designed to be immutable.

I understand that the patch changed behavior for RegionCoprocessorHost instantiation. If there
is a better approach to solving the issue of running mapreduce job on hadoop 2.0 *and* maintaining
immutability of CompoundConfiguration, I would be more than happy to adopt.
                
> Make mapreduce jobs pass based on 2.0.4-alpha
> ---------------------------------------------
>
>                 Key: HBASE-7904
>                 URL: https://issues.apache.org/jira/browse/HBASE-7904
>             Project: HBase
>          Issue Type: Task
>            Reporter: Ted Yu
>            Assignee: Ted Yu
>            Priority: Critical
>             Fix For: 0.95.0, 0.98.0
>
>         Attachments: 7904-addendum.txt, 7904.txt, 7904-v2-hadoop-2.0.txt, 7904-v2.txt,
7904-v4-hadoop-2.0.txt, 7904-v4.txt, 7904-v4.txt, 7904-v5-hadoop-2.0.txt, 7904-v5.txt, 7904-v6-hadoop-2.0.txt,
7904-v7-hadoop-2.0.txt, 7904-v8-hadoop-2.0.txt, 7904-v8.txt, 7904-v9-hadoop-2.0.txt, 7904-v9.txt,
hbase-7904-v3.txt
>
>
> 2.0.3-alpha has been released.
> We should upgrade the dependency.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message