hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sergey Shelukhin (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-5923) Cleanup checkAndXXX logic
Date Mon, 01 Apr 2013 22:33:15 GMT

    [ https://issues.apache.org/jira/browse/HBASE-5923?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13619260#comment-13619260
] 

Sergey Shelukhin commented on HBASE-5923:
-----------------------------------------

hmm...
                
> Cleanup checkAndXXX logic
> -------------------------
>
>                 Key: HBASE-5923
>                 URL: https://issues.apache.org/jira/browse/HBASE-5923
>             Project: HBase
>          Issue Type: Improvement
>          Components: Client, regionserver
>            Reporter: Lars Hofhansl
>            Assignee: Lars Hofhansl
>            Priority: Critical
>             Fix For: 0.95.0
>
>         Attachments: 5923-0.94.txt, 5923-trunk.txt
>
>
> 1. the checkAnd{Put|Delete} method that takes a CompareOP is not exposed via HTable[Interface].
> 2. there is unnecessary duplicate code in the check{Put|Delete} code in HRegionServer.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message