hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Himanshu Vashishtha (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-8156) Support for Namenode HA for non-idempotent operations
Date Fri, 22 Mar 2013 17:03:16 GMT

    [ https://issues.apache.org/jira/browse/HBASE-8156?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13610937#comment-13610937
] 

Himanshu Vashishtha commented on HBASE-8156:
--------------------------------------------

re: exists() call to NN: 
Since we are still working in this area, I think it is a good opportunity to reduce the number
of NN trips. 
I'll make the create/rename/delete methods in HRegionFileSystem to assume that exists check
has already been done before calling. Will correct the existing calls and also javadoc it.

re: javadoc and consistency; Sorry for missing it, will do it.

bq. You have two sleepBeforeRetry ? Shouldn't one call the other? Why have two at all?
Yea, there is also a static call to create directory. I needed two versions for that, but
the instance method can be made to call the static one in order to avoid code duplication.
Will do.

bq. I suppose the createDir just throws an exception if it fails? That is probably ok but
different shape on these methods.
Will work onto make these more consistent. Assume user already has check it like
{code}
if(fs.exists(Path p) && delete/rename())
{code}


                
> Support for Namenode HA for non-idempotent operations
> -----------------------------------------------------
>
>                 Key: HBASE-8156
>                 URL: https://issues.apache.org/jira/browse/HBASE-8156
>             Project: HBase
>          Issue Type: Sub-task
>          Components: Filesystem Integration
>    Affects Versions: 0.95.0
>            Reporter: Himanshu Vashishtha
>            Assignee: Himanshu Vashishtha
>             Fix For: 0.98.0
>
>         Attachments: HBase-8156-trunk-v1.patch, HBase-8156-trunk-v2.patch
>
>
> In hadoop 2 HA, non-idempotent operations are not retried at the hdfs side. This is by
design as retrying a non-idempotent operation might not be a good design choice for some use
case. 
> HBase needs to handle the retries for such operations at its end. 
> With HBase-7806, there is already some work going on for file system abstractions. There,
HReginFileSystem sits as an abstraction between region and FS. This jira is a move in the
same direction, where it adds retry functionality for non-idempotent calls such as create,
rename and delete in HRegionFileSystem class.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message