hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-8125) hbase-7435 broke upgrade from 0.94.2. 0.94.3 on hadoop < 1.0.x
Date Fri, 15 Mar 2013 23:44:16 GMT
stack created HBASE-8125:
----------------------------

             Summary: hbase-7435 broke upgrade from 0.94.2. 0.94.3 on hadoop < 1.0.x
                 Key: HBASE-8125
                 URL: https://issues.apache.org/jira/browse/HBASE-8125
             Project: HBase
          Issue Type: Bug
            Reporter: stack


>From some friends of ours at dropbox:

Index: src/main/java/org/apache/hadoop/hbase/io/hfile/Compression.java
===================================================================
--- src/main/java/org/apache/hadoop/hbase/io/hfile/Compression.java	(revision 1425723)
+++ src/main/java/org/apache/hadoop/hbase/io/hfile/Compression.java	(working copy)
@@ -33,6 +33,7 @@
 import org.apache.hadoop.io.compress.CompressionOutputStream;
 import org.apache.hadoop.io.compress.Compressor;
 import org.apache.hadoop.io.compress.Decompressor;
+import org.apache.hadoop.io.compress.DoNotPool;
 import org.apache.hadoop.io.compress.GzipCodec;
 import org.apache.hadoop.io.compress.DefaultCodec;
 import org.apache.hadoop.util.ReflectionUtils;
@@ -308,6 +309,9 @@
     public void returnDecompressor(Decompressor decompressor) {
       if (decompressor != null) {
         CodecPool.returnDecompressor(decompressor);
+        if (decompressor.getClass().isAnnotationPresent(DoNotPool.class)) {
+          decompressor.end();
+        }
       }
     }

breaks compatibility with hadoop-0.20.2-cdh3u2. 
+import org.apache.hadoop.io.compress.DoNotPool;
does not exist in that version of hadoop.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message