hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ramkrishna.s.vasudevan (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-7968) Packaging of Trunk and 0.95 does not create the dependent jars in the lib folder
Date Fri, 01 Mar 2013 09:39:12 GMT

    [ https://issues.apache.org/jira/browse/HBASE-7968?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13590373#comment-13590373
] 

ramkrishna.s.vasudevan commented on HBASE-7968:
-----------------------------------------------

These are my observations but not found out the root problem
In case of 0.94 we have the all.xml which takes care of the final packaging. All the dependencies
are copied into the lib folder.  Hope this is where it does
{code}
<dependencySets>
    <dependencySet>
      <outputDirectory>/lib</outputDirectory>
      <unpack>false</unpack>
      <scope>runtime</scope>
      <excludes>
        <exclude>org.apache.hbase:hbase</exclude>
      </excludes>
      <fileMode>0644</fileMode>
      <directoryMode>0644</directoryMode>
    </dependencySet>
  </dependencySets>
{code}

In trunk/0.95 we have 3 sets of xml files 
components.xml
hadoop-one-compat.xml
hadoop-two-compat.xml

In the trunk pom.xml we tend to call the 2 and 3rd xml for packaging.  But not the first one.

What am not very clear is the things were working fine till we branched out 0.95 and trunk.
 Is there something to do with this?  Not sure. 


                
> Packaging of Trunk and 0.95 does not create the dependent jars in the lib folder
> --------------------------------------------------------------------------------
>
>                 Key: HBASE-7968
>                 URL: https://issues.apache.org/jira/browse/HBASE-7968
>             Project: HBase
>          Issue Type: Bug
>    Affects Versions: 0.95.0, 0.98.0
>            Reporter: ramkrishna.s.vasudevan
>            Priority: Critical
>             Fix For: 0.95.0, 0.98.0
>
>
> After recent changes to trunk and 0.95 branch when i try to build and package, i do not
find the dependent jars in the lib folder.
> Prior to the changes, it was working fine.
> Am not a maven expert.  Will try to see what is going wrong here. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message