hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zavier Gao (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-7153) print gc option in hbase-env.sh affects hbase zkcli
Date Fri, 01 Mar 2013 02:09:14 GMT

    [ https://issues.apache.org/jira/browse/HBASE-7153?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13590177#comment-13590177
] 

Zavier Gao commented on HBASE-7153:
-----------------------------------

replace the  line [ SERVER_ARG=`"$bin"/hbase org.apache.hadoop.hbase.zookeeper.ZooKeeperMainServerArg`]
with [ SERVER_ARG=`"$bin"/hbase org.apache.hadoop.hbase.zookeeper.ZooKeeperMainServerArg |
sed -n -e '1p'` ] will solve this issue.
                
> print gc option in hbase-env.sh affects hbase zkcli
> ---------------------------------------------------
>
>                 Key: HBASE-7153
>                 URL: https://issues.apache.org/jira/browse/HBASE-7153
>             Project: HBase
>          Issue Type: Bug
>          Components: scripts
>    Affects Versions: 0.94.0
>            Reporter: wonderyl
>
> I un-commented the -verbose:gc option in hbase-env.sh, which print out the gc info.
> but when I use hbase zkcli to check zk, it can not connect to the server.
> the problem is zkcli uses "hbase org.apache.hadoop.hbase.zookeeper.ZooKeeperMainServerArg"
to get the server_arg in the script hbase. when gc verbose option is open, the output of ZooKeeperMainServerArg
is with gc info, which masses up with server_arg. and this is the reason stop zkcli working.
> I think the easiest way to fix this is to trim the gc info out of server_arg in the hbase
script.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message