hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-7937) Retry log rolling to support HA NN scenario
Date Wed, 27 Feb 2013 23:41:15 GMT

    [ https://issues.apache.org/jira/browse/HBASE-7937?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13588911#comment-13588911
] 

stack commented on HBASE-7937:
------------------------------

Why extra spacing:

+  private  int logRollRetryCount;

Can these be final?  Are they set in the Constructor?

Why not just set it back to a default with a log that this has happened rather than fail the
precondition?

+    Preconditions.checkArgument(this.logRollRetryCount > 0, 
+      "Log Roll retry count should be a positive number");

What is this about?

+          // there may be a case when fs has just become available; one can do one more retry
+          if (fsOk) throw ioe;

So if fs is ok, we throw the ioe?  Should we not go around again and retry?  (In comment says
'there may be a case'.. what is the case?

Are we incrementing in the for loop and below again when we do +          i++; ?  (i.e. incrementing
in two places?)

Do you think we should pause here:

+            Thread.sleep(pauseTime);

How long is default?

Are we holding up all writes when we are paused like this?

Looks like duplicated code.  Could it be avoided?

You add a new method to FSUtils but its guts are from checkFileSystemAvailable.  Why not make
it so you do not duplicate code, have checkFileSystemAvailable call your new method or factor
out a private method that both could use?





                
> Retry log rolling to support HA NN scenario
> -------------------------------------------
>
>                 Key: HBASE-7937
>                 URL: https://issues.apache.org/jira/browse/HBASE-7937
>             Project: HBase
>          Issue Type: Bug
>          Components: wal
>    Affects Versions: 0.94.5
>            Reporter: Himanshu Vashishtha
>            Assignee: Himanshu Vashishtha
>             Fix For: 0.95.0
>
>         Attachments: HBASE-7937-trunk.patch, HBASE-7937-v1.patch
>
>
> A failure in log rolling causes regionserver abort. In case of HA NN, it will be good
if there is a retry mechanism to roll the logs.
> A corresponding jira for MemStore retries is HBASE-7507.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message