hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "nkeywal (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-7927) Two versions of netty with hadoop.profile=2.0: 3.5.9 and 3.2.4
Date Mon, 25 Feb 2013 13:46:25 GMT

     [ https://issues.apache.org/jira/browse/HBASE-7927?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

nkeywal updated HBASE-7927:
---------------------------

    Summary: Two versions of netty with hadoop.profile=2.0: 3.5.9 and 3.2.4  (was: Bad classpath
generation)
    
> Two versions of netty with hadoop.profile=2.0: 3.5.9 and 3.2.4
> --------------------------------------------------------------
>
>                 Key: HBASE-7927
>                 URL: https://issues.apache.org/jira/browse/HBASE-7927
>             Project: HBase
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 0.96.0
>            Reporter: nkeywal
>
> I don't know why, but when you do a mvn dependency:tree, everything looks fine. When
you look at the generated target/cached_classpath.txt you see 2 versions of netty: netty-3.2.4.Final.jar
and netty-3.5.9.Final.jar.
> This is bad and can lead to unpredictable behavior.
> I haven't looked at the other dependencies.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message