hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-7797) Use consistent package name
Date Sat, 09 Feb 2013 22:17:13 GMT

    [ https://issues.apache.org/jira/browse/HBASE-7797?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13575288#comment-13575288

stack commented on HBASE-7797:

Sorry, let me say more.

As I see it, Cell Interface is a new grounding for our fundamental type.  I was thinking to
emphasize this new beginning, I thought it worth setting it apart by making it the first inhabitant
of our rightful namespace.
> Use consistent package name
> ---------------------------
>                 Key: HBASE-7797
>                 URL: https://issues.apache.org/jira/browse/HBASE-7797
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Enis Soztutar
>            Assignee: Enis Soztutar
>            Priority: Critical
>             Fix For: 0.96.0
> This has been discussed here: http://search-hadoop.com/m/bXxiV1MGsYi2. 
> We should not release 0.96 with two namespaces. This will cause further pain and confusion
in the future (like log4j configuration, greping logs, etc). 
> As much as I like it, I don't see us going o.a.hbase namespace, so let's move the Cell,
and prefix tree classes to o.a.hadoop.hbase. 

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message