hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Enis Soztutar (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-7773) rename StoreConfiguration, remove unnecessary method
Date Wed, 06 Feb 2013 03:57:12 GMT

    [ https://issues.apache.org/jira/browse/HBASE-7773?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13572119#comment-13572119

Enis Soztutar commented on HBASE-7773:

If StoreConfigInfo is only a view of HStore, shouldn't it be a super-interface of Store, as
in Store extends StoreConfigInfo? 
I actually like the name StoreConfiguration better than StoreConfigInformation, but won't
hold up the patch for this. 

> rename StoreConfiguration, remove unnecessary method
> ----------------------------------------------------
>                 Key: HBASE-7773
>                 URL: https://issues.apache.org/jira/browse/HBASE-7773
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Sergey Shelukhin
>            Assignee: Sergey Shelukhin
>            Priority: Minor
>         Attachments: HBASE-7773-v0.patch
> "StoreConfiguration" interface name is confusing, and one of the methods is unnecessary.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message