Return-Path: X-Original-To: apmail-hbase-issues-archive@www.apache.org Delivered-To: apmail-hbase-issues-archive@www.apache.org Received: from mail.apache.org (hermes.apache.org [140.211.11.3]) by minotaur.apache.org (Postfix) with SMTP id 88CEFD4A9 for ; Tue, 15 Jan 2013 23:48:13 +0000 (UTC) Received: (qmail 82282 invoked by uid 500); 15 Jan 2013 23:48:13 -0000 Delivered-To: apmail-hbase-issues-archive@hbase.apache.org Received: (qmail 82257 invoked by uid 500); 15 Jan 2013 23:48:13 -0000 Mailing-List: contact issues-help@hbase.apache.org; run by ezmlm Precedence: bulk List-Help: List-Unsubscribe: List-Post: List-Id: Delivered-To: mailing list issues@hbase.apache.org Received: (qmail 82248 invoked by uid 99); 15 Jan 2013 23:48:13 -0000 Received: from arcas.apache.org (HELO arcas.apache.org) (140.211.11.28) by apache.org (qpsmtpd/0.29) with ESMTP; Tue, 15 Jan 2013 23:48:13 +0000 Date: Tue, 15 Jan 2013 23:48:13 +0000 (UTC) From: "Ted Yu (JIRA)" To: issues@hbase.apache.org Message-ID: In-Reply-To: References: Subject: [jira] [Commented] (HBASE-7503) Add exists(List) in HTableInterface to allow multiple parallel exists at one time MIME-Version: 1.0 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 7bit X-JIRA-FingerPrint: 30527f35849b9dde25b450d4833f0394 [ https://issues.apache.org/jira/browse/HBASE-7503?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13554529#comment-13554529 ] Ted Yu commented on HBASE-7503: ------------------------------- {code} + * @param regionName the name of the region to get {code} 'to get' -> 'to get from' {code} + * @param get the client Gets {code} parameter name doesn't match: get -> gets {code} + Map> sortedGets = new HashMap>(); {code} Would getsByRegion be better name for the above variable ? {code} + HRegionInfo regionInfo = connection.getRegionLocation(tableName, get.getRow(), true).getRegionInfo(); {code} Wrap long line above. The third parameter is true, I think false should be passed so that locateRegion(name, row) is called: {code} return reload? relocateRegion(name, row): locateRegion(name, row); ... public HRegionLocation locateRegion(final byte [] tableName, final byte [] row) throws IOException{ return locateRegion(tableName, row, true, true); {code} Note the second last parameter is useCache. The rationale is to reduce query to .META. {code} public Pair getStartEndKeys() throws IOException { {code} An alternative is to call the above method and put each Get into corresponding bucket. {code} + * exists(List) is really a list of get() calls. Just us get(). {code} typo: us -> use Putting patch on review board would help reviewers. > Add exists(List) in HTableInterface to allow multiple parallel exists at one time > --------------------------------------------------------------------------------- > > Key: HBASE-7503 > URL: https://issues.apache.org/jira/browse/HBASE-7503 > Project: HBase > Issue Type: Improvement > Reporter: Jean-Marc Spaggiari > Assignee: Jean-Marc Spaggiari > Priority: Minor > Fix For: 0.96.0 > > Attachments: HBASE-7503-v0-trunk.patch, HBASE-7503-v1-trunk.patch, HBASE-7503-v2-trunk.patch, HBASE-7503-v2-trunk.patch, HBASE-7503-v3-trunk.patch, HBASE-7503-v4-trunk.patch, HBASE-7503-v5-trunk.patch > > Original Estimate: 5m > Remaining Estimate: 5m > > We need to have a Boolean[] exists(List gets) throws IOException method implemented in HTableInterface. -- This message is automatically generated by JIRA. If you think it was sent incorrectly, please contact your JIRA administrators For more information on JIRA, see: http://www.atlassian.com/software/jira