hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lars Hofhansl (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-7545) [replication] Break out TestReplication into manageable classes
Date Wed, 30 Jan 2013 19:35:12 GMT

    [ https://issues.apache.org/jira/browse/HBASE-7545?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13566820#comment-13566820
] 

Lars Hofhansl commented on HBASE-7545:
--------------------------------------

Interestingly I increased NB_RETRIES to 15 and now it gets to 944 edits before it fails. In
the previous two failed runs it got to 780 and 732 edits.
So this seems increase linearly suggesting that I should give this test more time on the slow
jenkins machines.

Or maybe better, increase the time specifically for loadTesting().

                
> [replication] Break out TestReplication into manageable classes
> ---------------------------------------------------------------
>
>                 Key: HBASE-7545
>                 URL: https://issues.apache.org/jira/browse/HBASE-7545
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Jean-Daniel Cryans
>            Assignee: Jean-Daniel Cryans
>             Fix For: 0.96.0, 0.94.5
>
>         Attachments: 7545-0.94.txt, 7545-0.94-v1.txt, HBASE-7545.patch
>
>
> This has been discussed before but after trying to debug the last failure on Jenkins
where I saw the time go back and forth (if you don't care about your own sanity do checkout
https://builds.apache.org/job/HBase-TRUNK/3726/testReport/junit/org.apache.hadoop.hbase.replication/TestReplicationWithCompression/testDeleteTypes/)
I think it is time to break out TestReplication.
> The difficulty is that the setup for the 2 clusters is a lot of code I don't want to
duplicate. I'm thinking that we can keep {{setUpBeforeClass}} there and have the other classes
extend TestReplication (which should also change name). I'm thinking of the following new
classes:
>  - TestReplicationSmallTests, contains the easy methods that don't mess around too much.
>  - TestReplicationQueueFailover, contains one test of the same name
>  - TestReplicationDisableInactivePeer, contains one test of the same name
>  - Rename TestReplicationWithCompression TestReplicationQueueFailoverWithCompression
and make it extends TestReplicationQueueFailover.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message