hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-4451) Improve zk node naming (/hbase/shutdown)
Date Wed, 16 Jan 2013 03:36:12 GMT

    [ https://issues.apache.org/jira/browse/HBASE-4451?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13554709#comment-13554709

stack commented on HBASE-4451:

+1 on patch.  Made new issue to see if other znodes we should rename.  Will wait on hadoopqa
before committing.
> Improve zk node naming (/hbase/shutdown)
> ----------------------------------------
>                 Key: HBASE-4451
>                 URL: https://issues.apache.org/jira/browse/HBASE-4451
>             Project: HBase
>          Issue Type: Improvement
>          Components: master
>    Affects Versions: 0.94.0
>            Reporter: Harsh J
>            Assignee: Devaraj Das
>            Priority: Critical
>              Labels: noob
>             Fix For: 0.96.0
>         Attachments: 4451-1.patch
> Right now the node {{/hbase/shutdown}} is used to indicate cluster status (cluster up,
cluster down).
> However, upon a chat with Lars George today, we feel that having a name {{/hbase/shutdown}}
is possibly bad. The {{/hbase/shutdown}} zknode contains a date when the cluster was _started_.
Now that is difficult to understand and digest, given that a person may connect to zk and
try to look at what it is about (they may think it 'shutdown' at that date.).
> I feel a better name may simply be: {{/hbase/running}}. Thoughts?

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message