hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lars Hofhansl (JIRA)" <j...@apache.org>
Subject [jira] [Created] (HBASE-7320) Replace calls to KeyValue.getBuffer with appropropriate calls to getRowArray, getFamilyArray(), getQualifierArray, and getValueArray
Date Tue, 11 Dec 2012 07:41:22 GMT
Lars Hofhansl created HBASE-7320:
------------------------------------

             Summary: Replace calls to KeyValue.getBuffer with appropropriate calls to getRowArray,
getFamilyArray(), getQualifierArray, and getValueArray
                 Key: HBASE-7320
                 URL: https://issues.apache.org/jira/browse/HBASE-7320
             Project: HBase
          Issue Type: Bug
            Reporter: Lars Hofhansl


In many places this is simple task of just replacing the method name.
There, however, quite a few places where we assume that:
# the entire KV is backed by a single byte array
# the KVs key portion is backed by a single byte array

Some of those can easily be fixed, others will need their own jiras.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message