hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Elliott Clark (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-7185) Create hbase-rpc module
Date Tue, 20 Nov 2012 18:39:00 GMT

    [ https://issues.apache.org/jira/browse/HBASE-7185?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13501365#comment-13501365

Elliott Clark commented on HBASE-7185:

Talked with stack and I think we both agree that rpc is probably a bad name for this module.
 Thinking hbase-protocol would be better.  It would convey more that this module contains
only the code of protobuf's that are pushed across the wire to ZK and to/from the servers.
 That's also why the ipc namespace is not moved into this module. The ipc module it much more
tied to our client and server implementations.  I wanted to make it possible for an external
client to use this module.
The skipping stuff is copied from the rest of the modules.  -Dskip-server-tests will skip
the server tests, -Dskip-common-tests will skip common etc.
> Create hbase-rpc module
> -----------------------
>                 Key: HBASE-7185
>                 URL: https://issues.apache.org/jira/browse/HBASE-7185
>             Project: HBase
>          Issue Type: Sub-task
>            Reporter: Elliott Clark
>            Assignee: Elliott Clark
>             Fix For: 0.96.0
>         Attachments: HBASE-7185-0.patch, HBASE-7185-1.patch
> Create an hbase-rpc module where protobuf's that can cross the wire(either to zk or from
a server) will be stored.  This should allow others to create clients without relying on too
much of the hbase code base.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message