hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "nkeywal (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-7104) HBase includes multiple versions of netty: 3.5.0; 3.2.4; 3.2.2
Date Tue, 13 Nov 2012 08:45:13 GMT

    [ https://issues.apache.org/jira/browse/HBASE-7104?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13496040#comment-13496040
] 

nkeywal commented on HBASE-7104:
--------------------------------

I suppose it works when you previously built hadoop 1.1 locally. I have the same error if
I delete my repository.
I don't why it happens this way. 

With this, I have:
[INFO] +- org.apache.hbase:hbase-hadoop1-compat:test-jar:tests:0.95-SNAPSHOT:test
[INFO] +- io.netty:netty:jar:3.5.9.Final:compile

[INFO] +- org.apache.hadoop:hadoop-client:jar:2.0.2-alpha:compile
[INFO] |  +- org.apache.hadoop:hadoop-mapreduce-client-app:jar:2.0.2-alpha:compile
[INFO] |  |  \- org.jboss.netty:netty:jar:3.2.4.Final:compile

So we still have the 3.2.4 when we build HBase, but as it comes only from the compat hadoop
2 module, let's say it's acceptable for now (I hope it will be changed in hadoop itself)...

Sorry for the mess...

                
> HBase includes multiple versions of netty: 3.5.0; 3.2.4; 3.2.2
> --------------------------------------------------------------
>
>                 Key: HBASE-7104
>                 URL: https://issues.apache.org/jira/browse/HBASE-7104
>             Project: HBase
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 0.96.0
>            Reporter: nkeywal
>            Assignee: nkeywal
>            Priority: Minor
>             Fix For: 0.96.0
>
>         Attachments: 7104.v1.patch
>
>
> We've got 3 of them on trunk.
> [INFO] org.apache.hbase:hbase-server:jar:0.95-SNAPSHOT
> [INFO] +- io.netty:netty:jar:3.5.0.Final:compile
> [INFO] +- org.apache.zookeeper:zookeeper:jar:3.4.3:compile
> [INFO] |  \- org.jboss.netty:netty:jar:3.2.2.Final:compile
> [INFO] org.apache.hbase:hbase-hadoop2-compat:jar:0.95-SNAPSHOT
> [INFO] +- org.apache.hadoop:hadoop-client:jar:2.0.2-alpha:compile
> [INFO] |  +- org.apache.hadoop:hadoop-mapreduce-client-app:jar:2.0.2-alpha:compile
> [INFO] |  |  \- org.jboss.netty:netty:jar:3.2.4.Final:compile
> The patch attached:
> - fixes this for hadoop 1 profile
> - bump the netty version to 3.5.9
> - does not fix it for hadoop 2. I don't know why, but I haven't investigate: as it's
still alpha may be they will change the version on hadoop side anyway.
> Tests are ok.
> I haven't really investigated the differences between netty 3.2 and 3.5. A quick search
seems to say it's ok, but don't hesitate to raise a warning...

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message