hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jimmy Xiang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-7140) mvn eclipse:eclipse command is failing
Date Fri, 09 Nov 2012 23:01:13 GMT

    [ https://issues.apache.org/jira/browse/HBASE-7140?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13494397#comment-13494397
] 

Jimmy Xiang commented on HBASE-7140:
------------------------------------

Can you go to the hbase-server folder to run "mvn eclipse:eclipse"?
                
> mvn eclipse:eclipse command is failing
> --------------------------------------
>
>                 Key: HBASE-7140
>                 URL: https://issues.apache.org/jira/browse/HBASE-7140
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Sujee Maniyam
>            Priority: Minor
>
> seems like building hadoop-one-snapshot is failing.  See error log
> [INFO] Scanning for projects...
> [INFO] ------------------------------------------------------------------------
> [INFO] Reactor Build Order:
> [INFO] 
> [INFO] HBase
> [INFO] HBase - Common
> [INFO] HBase - Hadoop Compatibility
> [INFO] HBase - Hadoop One Compatibility
> [INFO] HBase - Server
> [INFO] HBase - Hadoop Two Compatibility
> [INFO] HBase - Integration Tests
> [INFO] HBase - Examples
> [INFO]                                                                         
> [INFO] ------------------------------------------------------------------------
> [INFO] Building HBase 0.95-SNAPSHOT
> [INFO] ------------------------------------------------------------------------
> [INFO] 
> [INFO] >>> maven-eclipse-plugin:2.8:eclipse (default-cli) @ hbase >>>
> [INFO] 
> [INFO] --- maven-remote-resources-plugin:1.1:process (default) @ hbase ---
> [INFO] Setting property: classpath.resource.loader.class => 'org.codehaus.plexus.velocity.ContextClassLoaderResourceLoader'.
> [INFO] Setting property: velocimacro.messages.on => 'false'.
> [INFO] Setting property: resource.loader => 'classpath'.
> [INFO] Setting property: resource.manager.logwhenfound => 'false'.
> [INFO] 
> [INFO] <<< maven-eclipse-plugin:2.8:eclipse (default-cli) @ hbase <<<
> [INFO] 
> [INFO] --- maven-eclipse-plugin:2.8:eclipse (default-cli) @ hbase ---
> [INFO] Not running eclipse plugin goal for pom project
> [INFO] Using Eclipse Workspace: null
> [INFO] Adding default classpath container: org.eclipse.jdt.launching.JRE_CONTAINER
> [INFO]                                                                         
> [INFO] ------------------------------------------------------------------------
> [INFO] Building HBase - Common 0.95-SNAPSHOT
> [INFO] ------------------------------------------------------------------------
> [INFO] 
> [INFO] >>> maven-eclipse-plugin:2.8:eclipse (default-cli) @ hbase-common >>>
> [INFO] 
> [INFO] --- maven-remote-resources-plugin:1.1:process (default) @ hbase-common ---
> [INFO] 
> [INFO] <<< maven-eclipse-plugin:2.8:eclipse (default-cli) @ hbase-common <<<
> [INFO] 
> [INFO] --- maven-eclipse-plugin:2.8:eclipse (default-cli) @ hbase-common ---
> [INFO] Using Eclipse Workspace: null
> [INFO] Adding default classpath container: org.eclipse.jdt.launching.JRE_CONTAINER
> [INFO] File /Users/sujee/dev/hadoop/hbase-src/hbase-common/.project already exists.
>        Additional settings will be preserved, run mvn eclipse:clean if you want old settings
to be removed.
> [INFO] Wrote Eclipse project for "hbase-common" to /Users/sujee/dev/hadoop/hbase-src/hbase-common.
> [INFO] 
>        Sources for some artifacts are not available.
>        Please run the same goal with the -DdownloadSources=true parameter in order to
check remote repositories for sources.
>        List of artifacts without a source archive:
>          o com.google.guava:guava:12.0.1
>          o junit:junit:4.10-HBASE-1
>          o org.apache.hadoop:hadoop-core:1.1.0
>          o commons-io:commons-io:2.4
>          o commons-httpclient:commons-httpclient:3.0.1
>          o commons-codec:commons-codec:1.7
>          o commons-lang:commons-lang:2.6
>          o commons-net:commons-net:1.4.1
>          o org.mortbay.jetty:jsp-api-2.1:6.1.14
>          o org.mortbay.jetty:servlet-api-2.5:6.1.14
>          o org.mortbay.jetty:jsp-2.1:6.1.14
>          o org.apache.hadoop:hadoop-test:1.1.0
>          o org.apache.ftpserver:ftplet-api:1.0.0
>          o org.apache.mina:mina-core:2.0.0-M5
>          o org.slf4j:slf4j-api:1.4.3
>          o org.apache.ftpserver:ftpserver-core:1.0.0
>          o org.apache.ftpserver:ftpserver-deprecated:1.0.0-M2
>          o org.mockito:mockito-all:1.9.0
>          o org.slf4j:slf4j-log4j12:1.4.3
>        Javadoc for some artifacts is not available.
>        Please run the same goal with the -DdownloadJavadocs=true parameter in order to
check remote repositories for javadoc.
>        List of artifacts without a javadoc archive:
>          o com.google.guava:guava:12.0.1
>          o com.google.code.findbugs:jsr305:1.3.9
>          o commons-logging:commons-logging:1.1.1
>          o junit:junit:4.10-HBASE-1
>          o org.apache.hadoop:hadoop-core:1.1.0
>          o commons-cli:commons-cli:1.2
>          o xmlenc:xmlenc:0.52
>          o commons-io:commons-io:2.4
>          o commons-httpclient:commons-httpclient:3.0.1
>          o commons-codec:commons-codec:1.7
>          o org.apache.commons:commons-math:2.1
>          o commons-configuration:commons-configuration:1.6
>          o commons-collections:commons-collections:3.2.1
>          o commons-lang:commons-lang:2.6
>          o commons-digester:commons-digester:1.8
>          o commons-beanutils:commons-beanutils:1.7.0
>          o commons-beanutils:commons-beanutils-core:1.8.0
>          o commons-net:commons-net:1.4.1
>          o org.mortbay.jetty:jetty:6.1.26
>          o org.mortbay.jetty:jetty-util:6.1.26
>          o tomcat:jasper-runtime:5.5.23
>          o commons-el:commons-el:1.0
>          o tomcat:jasper-compiler:5.5.23
>          o org.mortbay.jetty:jsp-api-2.1:6.1.14
>          o org.mortbay.jetty:servlet-api-2.5:6.1.14
>          o org.mortbay.jetty:jsp-2.1:6.1.14
>          o org.codehaus.jackson:jackson-mapper-asl:1.8.8
>          o org.codehaus.jackson:jackson-core-asl:1.8.8
>          o org.apache.hadoop:hadoop-test:1.1.0
>          o org.apache.ftpserver:ftplet-api:1.0.0
>          o org.apache.mina:mina-core:2.0.0-M5
>          o org.slf4j:slf4j-api:1.4.3
>          o org.apache.ftpserver:ftpserver-core:1.0.0
>          o org.apache.ftpserver:ftpserver-deprecated:1.0.0-M2
>          o org.mockito:mockito-all:1.9.0
>          o org.slf4j:slf4j-log4j12:1.4.3
>          o log4j:log4j:1.2.17
> [INFO]                                                                         
> [INFO] ------------------------------------------------------------------------
> [INFO] Building HBase - Hadoop Compatibility 0.95-SNAPSHOT
> [INFO] ------------------------------------------------------------------------
> [INFO] 
> [INFO] >>> maven-eclipse-plugin:2.8:eclipse (default-cli) @ hbase-hadoop-compat
>>>
> [INFO] 
> [INFO] --- maven-remote-resources-plugin:1.1:process (default) @ hbase-hadoop-compat
---
> [INFO] 
> [INFO] <<< maven-eclipse-plugin:2.8:eclipse (default-cli) @ hbase-hadoop-compat
<<<
> [INFO] 
> [INFO] --- maven-eclipse-plugin:2.8:eclipse (default-cli) @ hbase-hadoop-compat ---
> [INFO] Using Eclipse Workspace: null
> [INFO] Adding default classpath container: org.eclipse.jdt.launching.JRE_CONTAINER
> [INFO] File /Users/sujee/dev/hadoop/hbase-src/hbase-hadoop-compat/.project already exists.
>        Additional settings will be preserved, run mvn eclipse:clean if you want old settings
to be removed.
> [INFO] Wrote Eclipse project for "hbase-hadoop-compat" to /Users/sujee/dev/hadoop/hbase-src/hbase-hadoop-compat.
> [INFO] 
>        Sources for some artifacts are not available.
>        Please run the same goal with the -DdownloadSources=true parameter in order to
check remote repositories for sources.
>        List of artifacts without a source archive:
>          o junit:junit:4.10-HBASE-1
>          o org.mockito:mockito-all:1.9.0
>        Javadoc for some artifacts is not available.
>        Please run the same goal with the -DdownloadJavadocs=true parameter in order to
check remote repositories for javadoc.
>        List of artifacts without a javadoc archive:
>          o commons-logging:commons-logging:1.1.1
>          o junit:junit:4.10-HBASE-1
>          o org.mockito:mockito-all:1.9.0
> [INFO]                                                                         
> [INFO] ------------------------------------------------------------------------
> [INFO] Building HBase - Hadoop One Compatibility 0.95-SNAPSHOT
> [INFO] ------------------------------------------------------------------------
> [INFO] 
> [INFO] >>> maven-eclipse-plugin:2.8:eclipse (default-cli) @ hbase-hadoop1-compat
>>>
> [INFO] 
> [INFO] --- maven-remote-resources-plugin:1.1:process (default) @ hbase-hadoop1-compat
---
> [INFO] ------------------------------------------------------------------------
> [INFO] Reactor Summary:
> [INFO] 
> [INFO] HBase ............................................. SUCCESS [1.534s]
> [INFO] HBase - Common .................................... SUCCESS [1.173s]
> [INFO] HBase - Hadoop Compatibility ...................... SUCCESS [0.058s]
> [INFO] HBase - Hadoop One Compatibility .................. FAILURE [0.098s]
> [INFO] HBase - Server .................................... SKIPPED
> [INFO] HBase - Hadoop Two Compatibility .................. SKIPPED
> [INFO] HBase - Integration Tests ......................... SKIPPED
> [INFO] HBase - Examples .................................. SKIPPED
> [INFO] ------------------------------------------------------------------------
> [INFO] BUILD FAILURE
> [INFO] ------------------------------------------------------------------------
> [INFO] Total time: 4.894s
> [INFO] Finished at: Fri Nov 09 14:49:27 PST 2012
> [INFO] Final Memory: 17M/81M
> [INFO] ------------------------------------------------------------------------
> [ERROR] Failed to execute goal org.apache.maven.plugins:maven-remote-resources-plugin:1.1:process
(default) on project hbase-hadoop1-compat: Failed to resolve dependencies for one or more
projects in the reactor. Reason: Missing:
> [ERROR] ----------
> [ERROR] 1) org.apache.hbase:hbase-hadoop-compat:jar:0.95-SNAPSHOT
> [ERROR] 
> [ERROR] Try downloading the file manually from the project website.
> [ERROR] 
> [ERROR] Then, install it using the command:
> [ERROR] mvn install:install-file -DgroupId=org.apache.hbase -DartifactId=hbase-hadoop-compat
-Dversion=0.95-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file
> [ERROR] 
> [ERROR] Alternatively, if you host your own repository you can deploy the file there:
> [ERROR] mvn deploy:deploy-file -DgroupId=org.apache.hbase -DartifactId=hbase-hadoop-compat
-Dversion=0.95-SNAPSHOT -Dpackaging=jar -Dfile=/path/to/file -Durl=[url] -DrepositoryId=[id]
> [ERROR] 
> [ERROR] Path to dependency:
> [ERROR] 1) org.apache.hbase:hbase-hadoop1-compat:jar:0.95-SNAPSHOT
> [ERROR] 2) org.apache.hbase:hbase-hadoop-compat:jar:0.95-SNAPSHOT
> [ERROR] 
> [ERROR] 2) org.apache.hbase:hbase-hadoop-compat:test-jar:tests:0.95-SNAPSHOT
> [ERROR] 
> [ERROR] Try downloading the file manually from the project website.
> [ERROR] 
> [ERROR] Then, install it using the command:
> [ERROR] mvn install:install-file -DgroupId=org.apache.hbase -DartifactId=hbase-hadoop-compat
-Dversion=0.95-SNAPSHOT -Dclassifier=tests -Dpackaging=test-jar -Dfile=/path/to/file
> [ERROR] 
> [ERROR] Alternatively, if you host your own repository you can deploy the file there:
> [ERROR] mvn deploy:deploy-file -DgroupId=org.apache.hbase -DartifactId=hbase-hadoop-compat
-Dversion=0.95-SNAPSHOT -Dclassifier=tests -Dpackaging=test-jar -Dfile=/path/to/file -Durl=[url]
-DrepositoryId=[id]
> [ERROR] 
> [ERROR] Path to dependency:
> [ERROR] 1) org.apache.hbase:hbase-hadoop1-compat:jar:0.95-SNAPSHOT
> [ERROR] 2) org.apache.hbase:hbase-hadoop-compat:test-jar:tests:0.95-SNAPSHOT
> [ERROR] 
> [ERROR] ----------
> [ERROR] 2 required artifacts are missing.
> [ERROR] 
> [ERROR] for artifact:
> [ERROR] org.apache.hbase:hbase-hadoop1-compat:jar:0.95-SNAPSHOT
> [ERROR] 
> [ERROR] from the specified remote repositories:
> [ERROR] cloudbees netty (http://repository-netty.forge.cloudbees.com/snapshot/, releases=true,
snapshots=true),
> [ERROR] apache release (https://repository.apache.org/content/repositories/releases/,
releases=true, snapshots=true),
> [ERROR] java.net (http://download.java.net/maven/2/, releases=true, snapshots=false),
> [ERROR] codehaus (http://repository.codehaus.org/, releases=true, snapshots=false),
> [ERROR] repository.jboss.org (http://repository.jboss.org/nexus/content/groups/public-jboss/,
releases=true, snapshots=false),
> [ERROR] ghelmling.testing (http://people.apache.org/~garyh/mvn/, releases=true, snapshots=true),
> [ERROR] apache.snapshots (http://repository.apache.org/snapshots, releases=false, snapshots=true),
> [ERROR] central (http://repo1.maven.org/maven2, releases=true, snapshots=false)
> [ERROR] -> [Help 1]
> [ERROR] 
> [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
> [ERROR] Re-run Maven using the -X switch to enable full debug logging.
> [ERROR] 
> [ERROR] For more information about the errors and possible solutions, please read the
following articles:
> [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
> [ERROR] 
> [ERROR] After correcting the problems, you can resume the build with the command
> [ERROR]   mvn <goals> -rf :hbase-hadoop1-compat

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message