hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-6929) Publish Hbase 0.94 artifacts build against hadoop-2.0
Date Wed, 14 Nov 2012 21:38:14 GMT

    [ https://issues.apache.org/jira/browse/HBASE-6929?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13497483#comment-13497483
] 

stack commented on HBASE-6929:
------------------------------

[~rvs] I just tried deploying an hbase artifact built against hadoop2 and its a PITA; the
pom needs a bunch of work it seems to get it to work (mvn trying to pull in hadoop-core-2.0.2-alpha
and ditto w/ hadoop-test).

We want to certify 0.96 against hadoop2, not 0.94.

So, I'm up for talking Mr. Roman.
                
> Publish Hbase 0.94 artifacts build against hadoop-2.0
> -----------------------------------------------------
>
>                 Key: HBASE-6929
>                 URL: https://issues.apache.org/jira/browse/HBASE-6929
>             Project: HBase
>          Issue Type: Task
>          Components: build
>    Affects Versions: 0.94.2
>            Reporter: Enis Soztutar
>         Attachments: 6929.txt, hbase-6929_v2.patch
>
>
> Downstream projects (flume, hive, pig, etc) depends on hbase, but since the hbase binaries
build with hadoop-2.0 are not pushed to maven, they cannot depend on them. AFAIK, hadoop 1
and 2 are not binary compatible, so we should also push hbase jars build with hadoop2.0 profile
into maven, possibly with version string like 0.94.2-hadoop2.0. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message