hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jean-Marc Spaggiari (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-7088) Duplicate code in RowCounter
Date Fri, 02 Nov 2012 22:36:13 GMT

    [ https://issues.apache.org/jira/browse/HBASE-7088?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13489803#comment-13489803
] 

Jean-Marc Spaggiari commented on HBASE-7088:
--------------------------------------------

Sure I will. Will try tonight, else, this week-end.
                
> Duplicate code in RowCounter
> ----------------------------
>
>                 Key: HBASE-7088
>                 URL: https://issues.apache.org/jira/browse/HBASE-7088
>             Project: HBase
>          Issue Type: Improvement
>          Components: mapreduce
>    Affects Versions: 0.94.2
>            Reporter: Jean-Marc Spaggiari
>            Assignee: Jean-Marc Spaggiari
>            Priority: Minor
>              Labels: mapreduce
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> On the RowCounter mapreduce class, there is a "scan.setFilter(new FirstKeyOnlyFilter());"
statement which is not required at line 125 since we have this on line 141:
>     if (qualifiers.size() == 0) {
>       scan.setFilter(new FirstKeyOnlyFilter());
>     } else {
>       scan.setFilter(new FirstKeyValueMatchingQualifiersFilter(qualifiers));
>     }
> Should the line 125 simply be removed?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message