hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Purtell (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-7063) Package name for compression should not contain hfile
Date Wed, 31 Oct 2012 19:36:12 GMT

    [ https://issues.apache.org/jira/browse/HBASE-7063?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13488147#comment-13488147

Andrew Purtell commented on HBASE-7063:

+1 I've had this thought before too Enis. Thanks for putting up an issue.
> Package name for compression should not contain hfile 
> ------------------------------------------------------
>                 Key: HBASE-7063
>                 URL: https://issues.apache.org/jira/browse/HBASE-7063
>             Project: HBase
>          Issue Type: Improvement
>          Components: HFile, io
>    Affects Versions: 0.96.0
>            Reporter: Enis Soztutar
>              Labels: noob
> Compression codecs does not have any hfile specific functionality, and can be used elsewhere
(RPC, hlog, see: HBASE-6966)
> We should move o.a.h.h.io.hfile.Compession and related files from io.hfile pacakge. We
can use io.compress to be in line with hadoop. 

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message