hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-6410) Move RegionServer Metrics to metrics2
Date Sat, 27 Oct 2012 05:05:12 GMT

    [ https://issues.apache.org/jira/browse/HBASE-6410?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13485359#comment-13485359

stack commented on HBASE-6410:

RB is messing me up.  Filled out comments on first page twice and it lost them.  Here they

Usual style is to have spaces around operators (the '+' in this case).   No biggie.

Add comment why you are predefining all these strings -- because they are used later in h1
and h2 compat modules.  There are two places where you define a lump of static strings.  Say
why -- that they will be used downstream in implemenations?

On 'getServerName' in Interfaces... "Was going to say why this in this Interface when its
in the Server Interface implemented by Master -- then thinking on it, better to explicitly
declare what you need in your Interface rather than have a non-declared dependency..."

Remove 'Master' from method names because context is enough... e.g. getStartTime instead of
getMasterStartTime.  Ditto in the RegionServer wrapper Interface.

For the region wrapper, will there be a day when we should pass the Put object to the updatePut,
etc., so it can glean metrics by looking at the actual Put?  That is future stuff.

Its createServer and not createGeneral in the factory.

In replication source, fix the bean names.  Has HRegionServer instead of RegionServer... in
a few places.

Rest bean should be called REST I think rather than Rest or rest.

> Move RegionServer Metrics to metrics2
> -------------------------------------
>                 Key: HBASE-6410
>                 URL: https://issues.apache.org/jira/browse/HBASE-6410
>             Project: HBase
>          Issue Type: Sub-task
>          Components: metrics
>    Affects Versions: 0.96.0
>            Reporter: Elliott Clark
>            Assignee: Elliott Clark
>            Priority: Blocker
>         Attachments: HBASE-6410-1.patch, HBASE-6410-2.patch, HBASE-6410-3.patch, HBASE-6410-4.patch,
HBASE-6410-5.patch, HBASE-6410-6.patch, HBASE-6410.patch
> Move RegionServer Metrics to metrics2

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message