hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "stack (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-6929) Publish Hbase 0.94 artifacts build against hadoop-2.0
Date Mon, 22 Oct 2012 20:26:13 GMT

    [ https://issues.apache.org/jira/browse/HBASE-6929?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13481752#comment-13481752
] 

stack commented on HBASE-6929:
------------------------------

Yes, we have not published a secure jar to maven.  We should have.  We just shipped two tgz
bundles, secure and insecure.

Yes, this is a problem we need to fix.

On changing the version being the only way around this issue, I agree.  Jon Hsieh and I talked
w/ a Maven'y fellow who suggested similar -- Andrew Bayer.  Even if we could make it work
w/ classifiers, it would probably be a deceit; I would not trust that downloaded, maven would
pull in the proper dependencies.

The hadoop-api-evolution table made me violently sick.

Roman, on HBASE-4850, I don't think we can do what is suggested there (Commented to that effect).

I like the patch you suggest Enis.

What do we do in hbase 1.0, say, where minimum required is indeed h2.  Don't we want our version
to be hbase in that case and not hbase-*-hadoop2?  You think w/ your patch, maven repo will
have hbase-*-hadoop2 and it will be just fine when hbase itself moves to hadoop2?  (We'll
have a hadoop3 version around this time too?)

Oh, we don't need to do a security artifact in  maven for 0.96.  We should have published
one for 0.94 and before.


                
> Publish Hbase 0.94 artifacts build against hadoop-2.0
> -----------------------------------------------------
>
>                 Key: HBASE-6929
>                 URL: https://issues.apache.org/jira/browse/HBASE-6929
>             Project: HBase
>          Issue Type: Task
>          Components: build
>    Affects Versions: 0.94.2
>            Reporter: Enis Soztutar
>         Attachments: 6929.txt, hbase-6929_v2.patch
>
>
> Downstream projects (flume, hive, pig, etc) depends on hbase, but since the hbase binaries
build with hadoop-2.0 are not pushed to maven, they cannot depend on them. AFAIK, hadoop 1
and 2 are not binary compatible, so we should also push hbase jars build with hadoop2.0 profile
into maven, possibly with version string like 0.94.2-hadoop2.0. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message