hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ted Yu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-6658) Rename WritableByteArrayComparable to something not mentioning Writable
Date Fri, 07 Sep 2012 23:51:08 GMT

    [ https://issues.apache.org/jira/browse/HBASE-6658?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13451145#comment-13451145
] 

Ted Yu commented on HBASE-6658:
-------------------------------

See http://docs.oracle.com/javase/6/docs/api/java/util/Comparator.html

While Comparable defines compareTo() method which is not in Comparator interface.

I suggest keeping Comparable in class names and only dropping Writable.
                
> Rename WritableByteArrayComparable to something not mentioning Writable
> -----------------------------------------------------------------------
>
>                 Key: HBASE-6658
>                 URL: https://issues.apache.org/jira/browse/HBASE-6658
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Gregory Chanan
>            Assignee: Gregory Chanan
>            Priority: Minor
>             Fix For: 0.96.0
>
>         Attachments: HBASE-6658.patch
>
>
> After HBASE-6477, WritableByteArrayComparable will no longer be Writable, so should be
renamed.
> Current idea is ByteArrayComparator (since all the derived classes are *Comparator not
*Comparable), but I'm open to suggestions.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message