hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-6658) Rename WritableByteArrayComparable to something not mentioning Writable
Date Sat, 08 Sep 2012 00:13:07 GMT

    [ https://issues.apache.org/jira/browse/HBASE-6658?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13451164#comment-13451164
] 

Hadoop QA commented on HBASE-6658:
----------------------------------

-1 overall.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12544329/HBASE-6710-v2.patch
  against trunk revision .

    +1 @author.  The patch does not contain any @author tags.

    +1 tests included.  The patch appears to include 8 new or modified tests.

    -1 patch.  The patch command could not apply the patch.

Console output: https://builds.apache.org/job/PreCommit-HBASE-Build/2824//console

This message is automatically generated.
                
> Rename WritableByteArrayComparable to something not mentioning Writable
> -----------------------------------------------------------------------
>
>                 Key: HBASE-6658
>                 URL: https://issues.apache.org/jira/browse/HBASE-6658
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Gregory Chanan
>            Assignee: Gregory Chanan
>            Priority: Minor
>             Fix For: 0.96.0
>
>         Attachments: HBASE-6658.patch, HBASE-6710-v2.patch
>
>
> After HBASE-6477, WritableByteArrayComparable will no longer be Writable, so should be
renamed.
> Current idea is ByteArrayComparator (since all the derived classes are *Comparator not
*Comparable), but I'm open to suggestions.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message