hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gregory Chanan (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-6658) Rename WritableByteArrayComparable to something not mentioning Writable
Date Sat, 08 Sep 2012 00:19:08 GMT

     [ https://issues.apache.org/jira/browse/HBASE-6658?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Gregory Chanan updated HBASE-6658:
----------------------------------

    Attachment: HBASE-6658-v3.patch

Messed that patch up, trying again.
                
> Rename WritableByteArrayComparable to something not mentioning Writable
> -----------------------------------------------------------------------
>
>                 Key: HBASE-6658
>                 URL: https://issues.apache.org/jira/browse/HBASE-6658
>             Project: HBase
>          Issue Type: Bug
>            Reporter: Gregory Chanan
>            Assignee: Gregory Chanan
>            Priority: Minor
>             Fix For: 0.96.0
>
>         Attachments: HBASE-6658.patch, HBASE-6658-v3.patch
>
>
> After HBASE-6477, WritableByteArrayComparable will no longer be Writable, so should be
renamed.
> Current idea is ByteArrayComparator (since all the derived classes are *Comparator not
*Comparable), but I'm open to suggestions.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message