hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ian Varley (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-5412) HBase book, section 2.6.4, has deficient list of client dependencies
Date Sat, 01 Sep 2012 13:43:07 GMT

    [ https://issues.apache.org/jira/browse/HBASE-5412?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13446704#comment-13446704
] 

Ian Varley commented on HBASE-5412:
-----------------------------------

It was filed in .92, and all of the JARs still seem to be the same in trunk (except the HBase
jar). I think it kind of goes without saying that you'd want to use the right HBase JAR for
whatever server version you have, but maybe we should expand? In any case, it's a minor clarification
thing so probably not worth a lot of back & forth. If it's any hassle doing it against
0.92, then just do it in 0.94. And likewise if it's any hassle doing it against 0.94, just
do it in trunk. :)
                
> HBase book, section 2.6.4, has deficient list of client dependencies
> --------------------------------------------------------------------
>
>                 Key: HBASE-5412
>                 URL: https://issues.apache.org/jira/browse/HBASE-5412
>             Project: HBase
>          Issue Type: Bug
>          Components: documentation
>    Affects Versions: 0.92.0
>            Reporter: Mike Spreitzer
>            Assignee: Doug Meil
>            Priority: Minor
>              Labels: documentation
>         Attachments: HBASE-5412.patch
>
>   Original Estimate: 1h
>  Remaining Estimate: 1h
>
> The current text in section 2.6.4 of the HBase book says this about client dependencies:
> Minimally, a client of HBase needs the hbase, hadoop, log4j, commons-logging, commons-lang,
and ZooKeeper jars in its CLASSPATH connecting to a cluster.
> I tried that, and got an exception due to a class not being found.  I fixed that by searching
for that class in the jars in lib/, and tried again.  Got an exception, due to a different
class not found.  I iterated until it worked.  When I was done, I found myself using the following
JARs:
> commons-configuration-1.6.jar  hadoop-core-1.0.0.jar  slf4j-api-1.5.8.jar
> commons-lang-2.5.jar           hbase-0.92.0.jar       slf4j-log4j12-1.5.8.jar
> commons-logging-1.1.1.jar      log4j-1.2.16.jar       zookeeper-3.4.2.jar

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message