hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lars Hofhansl (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-6569) Extract HStore interface from Store
Date Thu, 16 Aug 2012 05:57:38 GMT

    [ https://issues.apache.org/jira/browse/HBASE-6569?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13435776#comment-13435776

Lars Hofhansl commented on HBASE-6569:

Shouldn't it then be "Store" and "StoreImpl"?
(Note that this falls squarely in the "I couldn't care less" category for me, just saying
that's what we used in some other places, maybe we need to generally agree on a convention
for HBase).

> Extract HStore interface from Store
> -----------------------------------
>                 Key: HBASE-6569
>                 URL: https://issues.apache.org/jira/browse/HBASE-6569
>             Project: HBase
>          Issue Type: Sub-task
>    Affects Versions: 0.96.0
>            Reporter: Jesse Yates
>            Assignee: Jesse Yates
>             Fix For: 0.96.0
>         Attachments: 6569-v3.patch, java_HBASE-6569-v0.patch
> Currently Store.java is a top-level class. However, we need to to use the same interface
for snapshots (HBASE-6055), and potentially other uses-cases as well, but subclassing is 'dirty'
given the amount of state that a Store currently builds up on instantiation.
> For snapshots, we just need to modify the Store actions slightly, making a composition
with interface inheritance design very appealing (meaning we need an interface for Store).

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message