hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zhihong Ted Yu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (HBASE-5151) Rename "hbase.skip.errors" in HRegion as it is too general-sounding.
Date Wed, 11 Jul 2012 22:07:34 GMT

    [ https://issues.apache.org/jira/browse/HBASE-5151?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13412056#comment-13412056

Zhihong Ted Yu commented on HBASE-5151:

It turns out that the first patch was syntactically correct.
Harsh added something in patch v2 which wouldn't pass compilation.

Currently Hadoop QA wouldn't post back if there is compilation error.
However, Stack wasn't aware of the above and integrated patch v2.

This is another reason we need versioning in patch filenames so that such mistakes can be
more easily avoided.
> Rename "hbase.skip.errors" in HRegion as it is too general-sounding.
> --------------------------------------------------------------------
>                 Key: HBASE-5151
>                 URL: https://issues.apache.org/jira/browse/HBASE-5151
>             Project: HBase
>          Issue Type: Sub-task
>          Components: documentation
>    Affects Versions: 0.94.0
>            Reporter: Harsh J
>            Assignee: Harsh J
>             Fix For: 0.96.0
>         Attachments: HBASE-5151.amend.patch, HBASE-5151.amend.wrapped.patch, HBASE-5151.patch,
HBASE-5151.patch, HBASE-5151.patch
> We should rename "hbase.skip.errors", used in HRegion.java for skipping errors when replaying
edits. It should probably be something more like "hbase.hregion.edits.replay.skip.errors"
or so.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message