hbase-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Harsh J (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (HBASE-5151) Rename "hbase.skip.errors" in HRegion as it is too general-sounding.
Date Mon, 09 Jul 2012 05:38:33 GMT

     [ https://issues.apache.org/jira/browse/HBASE-5151?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Harsh J updated HBASE-5151:

    Attachment: HBASE-5151.patch

This patch deprecates "hbase.skip.errors" in favor of the new style config mentioned above.

Ideally I'd have used Configuration.addDeprecatedKeys but thats sadly available only in Hadoop
2.x onwards. I think it will do HBase a good deal someday in future to shed off multiple Hadoop
deps to a single, rolling one alone. That day, we can have proper deprecation features in
HBaseConfiguration without duplicating code or hacking around, or even having extra code like
this patch required.
> Rename "hbase.skip.errors" in HRegion as it is too general-sounding.
> --------------------------------------------------------------------
>                 Key: HBASE-5151
>                 URL: https://issues.apache.org/jira/browse/HBASE-5151
>             Project: HBase
>          Issue Type: Sub-task
>          Components: documentation
>    Affects Versions: 0.94.0
>            Reporter: Harsh J
>         Attachments: HBASE-5151.patch
> We should rename "hbase.skip.errors", used in HRegion.java for skipping errors when replaying
edits. It should probably be something more like "hbase.hregion.edits.replay.skip.errors"
or so.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message